QoS y VoIP

Muchas veces nos encontramos con problemas de sonido y ecos entre terminales VoIP. Se habla mucho de los problemas provenientes de convertir la comunicación analógica en IP, pero en este caso me refiero a la comunicación IP-IP.

Es muy importante disponer de una red planificada al efecto, si se puede separar la voz de los datos, mejor. Unos switches gestionables que prioricen por tipo de tráfico sería estupendo. Pero la mayoría de los problemas vienen cuando la comunicación se realiza a través de Internet con usuarios nómadas u otras sedes. Aquí es donde implementar QoS es más necesario, y pocas veces se utiliza.

Con QoS podemos priorizar el tráfico de VoIP sobre el resto de servicios IP, incluso reservarle un ancho de banda exclusivo. Desde Excom, utilizamos Mikrotik como complemento a los proyectos de Asterisk y VoIP para implementar la calidad del servicio (QoS).

Por ejemplo, si utilizamos el servidor Asterisk exclusivamente para el servicio de VoIP, podríamos marcar los paquetes que entran y salen de este servidor:

/ip firewall mangle add chain=forward src-address=IP_Asterisk action=mark-packet new-packet-mark=VoIP disabled=no
/ip firewall mangle add chain=forward dst-address=IP_Asterisk action=mark-packet new-packet-mark=VoIP disabled=no

Luego darle una prioridad 1 a estos paquetes con una cola simple:

/queue simple add name=”Cola-VoIP” priority=1 packet-marks=VoIP disabled=no

Y a lo mejor limitar el resto de nuestro tráfico a 512 con una prioridad mucho más baja:

/queue simple add name=”Cola-Resto” priority=5 max-limit=512000/512000 disabled=no

Simplemente con esto mejoraremos notablemente la calidad de las conversaciones IP-IP entre sedes o con usuarios nómadas.

Sindicar contenido

Suscríbete o enlázate conmigo:

3 Responses to QoS y VoIP

  1. Ernesto Orozco 13 noviembre, 2009 en 21:40 #

    Muy buen articulo felicidades

  2. Radif Elnoun 20 abril, 2010 en 16:26 #

    Hola Luis, me encanta tu blog, es bestial!.
    Te comento algo, que seguro que puedes ayudarme.
    Tengo u n cyber y necesito dar prioridad a un juego ( por ejemplo Counter Strike ) , Frente a otras aplicaciones que tiren de mi red (EMULE, ARES, DescargasDirectas, etc)
    sabes si puedo hacer algo asi? Tiene que ver con el servicio Quos?.

Trackbacks/Pingbacks

  1. QoS y VoIP | Blackhold - 1 marzo, 2011

    […] Fuente: luisabenza.com […]

Deja un comentario